GitHub header

High latency on webhook API requests

Incident Report for GitHub

Resolved

Between February 26, 2026 UTC and February 27, 2026 UTC, customers hitting the webhooks delivery API may have experienced higher latency or failed requests. During the impact window, 0.82% of requests took longer than 3s and 0.004% resulted in a 500 error response.

Our monitors caught the impact on the individual backing data source, and we were able to attribute the degradation to a noisy neighbor effect due requests to a specific webhook generating excessive load on the API. The incident was mitigated once traffic from the specific hook decreased.

We have since added a rate limiter for this webhooks API to prevent similar spikes in usage impacting others and will further refine the rate limits for other webhook API routes to help prevent similar occurrences in the future.
Posted Feb 27, 2026 - 00:04 UTC

Update

Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted Feb 27, 2026 - 00:02 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Feb 27, 2026 - 00:01 UTC
This incident affected: Webhooks.