GitHub header

Incident with Copilot Agent Sessions impacting CCA/CCR

Incident Report for GitHub

Resolved

On February 25, 2026, between 15:05 UTC and 16:34 UTC, the Copilot coding agent service was degraded, resulting in errors for 5% of all requests and impacting users starting or interacting with agent sessions.

This was due to an internal service dependency running out of allocated resources (memory and CPU). We mitigated the incident by adjusting the resource allocation for the affected service, which restored normal operations for the coding agent service.

We are working to implement proactive monitoring for resource exhaustion across our services, review and update resource allocations, and improve our alerting capabilities to reduce our time to detection and mitigation of similar issues in the future.
Posted Feb 25, 2026 - 16:44 UTC

Investigating

We are investigating reports of degraded performance for Copilot
Posted Feb 25, 2026 - 16:38 UTC
This incident affected: Copilot.